IX2215の設定メモ

これは何もわからんおたくがとりあえずDHCPな環境でv4のみ動くようにするためのメモです。CATVだからなのかv4しかないのよね。NGN?ひかり電話?そんなのないよ

マニュアル : UNIVERGE IXシリーズ | NEC
コマンドリファレンスマニュアル | NEC Manuals

yuzuki-ix2215(config)# show running-config 
! NEC Portable Internetwork Core Operating System Software
! IX Series IX2215 (magellan-sec) Software, Version 10.3.13, RELEASE SOFTWARE
! Compiled Jun 23-Tue-2020 13:38:34 JST #2
! Current time Aug 04-Tue-2020 20:12:06 JST
!
hostname yuzuki-ix2215
timezone +09 00
!
username username password hash XXXXXXXXXXXX administrator
!
ntp server 61.205.120.130 retry 1 timeout 30
ntp interval 86400
!
!
ip ufs-cache enable
ip dhcp enable
!
!
!
!
!
!
!
!
!
!
proxy-dns ip enable
!
!
ssh-server ip port 1222
ssh-server ip enable
!
!
!
!
ip dhcp profile pf1
  assignable-range 192.168.222.100 192.168.222.200
  subnet-mask 255.255.255.0
  default-gateway 192.168.222.254
  dns-server 192.168.222.254
  lease-time 86400
!
device GigaEthernet0
!
device GigaEthernet1
!
device GigaEthernet2
!
device BRI0
  isdn switch-type hsd128k
!
device USB0
  shutdown
!
interface GigaEthernet0.0
  ip address dhcp receive-default
  ip tcp adjust-mss auto
  ip napt enable
  ip napt hairpinning
  ip napt service http 192.168.222.xxx none tcp 80
  ip napt service https 192.168.222.xxx none tcp 443
  ip napt service somethingservice 192.168.222.xxx none tcp 1222
  no shutdown
!
interface GigaEthernet1.0
  no ip address
  shutdown
!
interface GigaEthernet2.0
  ip address 192.168.222.254/24
  ip dhcp binding pf1
  no shutdown
!       
interface BRI0.0
  encapsulation ppp
  no auto-connect
  no ip address
  shutdown
!       
interface USB-Serial0.0
  encapsulation ppp
  no auto-connect
  no ip address
  shutdown
!       
interface Loopback0.0
  no ip address
!       
interface Null0.0
  no ip address

基本的な操作

show系は基本的に入った直後のコマンドで大丈夫だけど他は基本的にconfigの何かしらに入らないといけない(Interfaceとかip dhcp profile hogehogeとか)っていうことを覚えておけば良いと思います。

大体これshow running-config通りなのでわかっちゃえば簡単みたいですねすごい

NECのPCにNECのルーターを繋げる図

最初はシリアルでコンソール入ってやってました。rloginで普通に入れるので助かった。設定はマニュアルに書いてあるので省略。
何らかの理由で二重接続しようとするとコケるのと、再接続時に特に何も出てこない(繋がってる)のが注意事項かな。設定自体は基本的に即時反映みたいです。DHCPでしくじったときはPC側のLANコネクタを指し直してみると吉かも

SSHはenableしただけでは繋がらない(本体側の秘密鍵作成必要 参考:ix2215にsshでログインするには。: 技術系memo)ので

pki private-key generate rsa

も唱えておきましょう。ポート変更はお好みで(表に出す勇気はないけど趣味で変更)

SSHで入るときはID/PASS指定しておけば入れます。
そういえばアカウント設定忘れてましたね

username tana3n password plane passwordhogehoge
config
ip dhcp profile lan
  assignable-range 192.168.222.100 192.168.222.200
  subnet-mask 255.255.255.0
  default-gateway 192.168.222.254
  dns-server 192.168.222.254
  lease-time 86400
exit

概念としてはconfigに書いてあるとおりなんですがこれを例にするとconfigでconfigモードにはいってdhcpのプロファイル設定に入ってから任意の設定してexitみたいな感じです。最初はハマったけどわかればわかりやすいですねすごい。

DHCP

proxy-dns ip enable
ip dhcp enable
ip dhcp profile hogehoge
(以下profile内で)
assignable-range 192.168.222.100 192.168.222.200
  subnet-mask 255.255.255.0
  default-gateway 192.168.222.254
  dns-server 192.168.222.254
  lease-time 86400

ちょっと前にconfigの概念的なところでかいた感じと同じですが、DHCPの設定はとりあえず端末数もそこまでないので100降っておけば何とかなるだろうと(様子見)。一般的な感じなのでサブネットマスクは普通のを。デフォルトゲートウェイとDNSサーバーは後述します。リースタイムはまあ適当に。一般家庭なのでこんなものかと思う知らないけど。

LAN側(GigaEthernet2.0)

ip address 192.168.222.254/24
  ip dhcp binding pf1
  no shutdown

GigaEthernet2.0で唱えてるこれは2.0側から見える(8つのハブ側)IX2215のIPで、一般向けのルーターでいうと192.168.1.1と同じ。別に1じゃなくて好きなところに振ってあげればいいよねって言うだけの話なのでややこしく考える必要なし。最後の/24は192.168.222.0~255を使うみたいな感じでサブネットマスクという、さっきDHCPの説明で省いたdns-serverとかdefault-gatewayとかも基本的にIXに投げるなら同じに設定。

WAN側(GigaEthernet0.0)をDHCPで

ip address dhcp receive-default
ip tcp adjust-mss auto
ip napt enable

インターネット接続 (CATV): UNIVERGE IXシリーズ | NEC
サンプルコンフィグとかでもあるように
show ip interfaceでGigaEthernet0.0側からIP拾えてるかとか確認できる。
ので、繋がらないときは切り分けで見た方がいいです。(ここで拾えていればDHCPしくじってるだけかもしれないので)。DHCPのアレなので一回ONU再起動はした方が安全(つけっぱで変えたらダメとかありがち)

その他

ポート開放(ポートマッピングとかともいう)とかヘアピンNAT(NATループバック)は

interface GigaEthernet0.0
  ip napt hairpinning
  ip napt service http 接続先のIP
  ip napt service https 接続先のIP
  ip napt service 任意の名前 接続先のIP none tcp 1222

リファレンスマニュアルの8-35,36あたりに書いてありました(Ver10.3の現段階では)
この設定はWAN側のGigaEthernet0.0で設定すること(ここ大事)

VPNとかは今のところ触ってませんがこれでちゃんと動いてるので追々他の昨日も触っていければ良いなと思います。

あと忘れてたけどファームは適当にsoftware-updateで唱えて適当にHTTP鯖を立てて食わせるのが楽だと思います(HFSとかがお手軽)

設定変更時はconfigでwrite memoryを忘れない。再起動はreloadとかrestartです。あんまり使わないと思うけど一応。電源OFF時はBusyランプだけ気をつけておとすと。

コメントする

メールアドレスが公開されることはありません。

このサイトはスパムを低減するために Akismet を使っています。コメントデータの処理方法の詳細はこちらをご覧ください